WBITT

We Bring In Tomorrows Technology

  • Full Screen
  • Wide Screen
  • Narrow Screen
  • Increase font size
  • Default font size
  • Decrease font size

Installation of CentOS fails through PXE, on XEN and KVM

E-mail Print PDF
User Rating: / 5
PoorBest 

Assalam-u-alaikum,

A couple of days ago, I was testing my install / kickstart scripts, on KVM, and found out that my installation of CentOS 5.3 (i386) failed each time I installed it. KVM / qemu crashed each time, with output similar to what it looks like below:-

Python traceback:

Traceback (most recent call first):
File "/usr/lib/python2.4/subprocess.py", line 975, in _execute_child
raise child_exception
File "/usr/lib/python2.4/subprocess.py", line 542, in __init__
errread, errwrite)
File "/usr/lib/anaconda/iutil.py", line 488, in inVmware
proc = subprocess.Popen(lspci, stdout = subprocess.PIPE)
File "/usr/lib/anaconda/yuminstall.py", line 860, in doGroupSetup
if iutil.inXen() or iutil.inVmware() or \
File "/usr/lib/anaconda/yuminstall.py", line 942, in doRepoSetup
self.doGroupSetup()
File "/usr/lib/anaconda/backend.py", line 172, in doRepoSetup
anaconda.backend.doRepoSetup(anaconda)
File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
rc = stepFunc(self.anaconda)
File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
self.moveStep()
File "/usr/lib/anaconda/text.py", line 721, in run
anaconda.dispatch.gotoNext()
File "/usr/bin/anaconda", line 1006, in ?
anaconda.intf.run(anaconda)
OSError: [Errno 2] No such file or directory
 
Reference: https://bugzilla.redhat.com/show_bug.cgi?id=476476
 
I was using 3 GB virtual disk and 256 MB of RAM for the virtual machine. ,,,,,,,,,,,, and ,,,,,,,that was the exact problem, though it is not mentioned any where in the docs, nor the crash tells anything about it. I mean, 256 MB RAM. It is not enough for CENTOS 5.3 to install through PXE, any more. Though the CD install works. 
So, increasing the RAM to 384, even to 512, magically fixed the problem. I burned two days on this one, ripping apart my kickstart configurations, checking DHCP, TFTP, Apache , etc etc. It was a real waste of time. Any way, it's done now.
I hope this will help someone save his time. 
 
Regards,
Kamran 
 
 
 
 
 

 

 

You are here How To / Tutorials Installation of CentOS fails through PXE, on XEN and KVM